Back
Downtime
Downtime
Flooding affecting Croft Servers
Started 12 Jun at 09:23pm BST, resolved 20 Jun at 12:23pm BST.
Croft Server
Resolved
The servers have been reconnected
Posted 20 Jun at 12:23pm BST.
Updated
The main server and backup server at Croft Design are down due to flooding
Files stored on these servers are unavailable and there may be some issues with logging into computers you haven't logged into recently
Posted 12 Jun at 09:25pm BST.
Created
Power was lost due to flooding
Posted 12 Jun at 09:23pm BST.